Microsoft excell frågor

Diskussion i 'Övrigt' startad av Tomas Lindblom, 1 mars 2015.

  1. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Hej!

    Jag har ett excell ark där jag skriver upp alla viner jag dricker, och i kolumn C så skriver jag vilket land vinet kommer ifrån.

    I blad 2 har jag ett cirkeldiagram som visar de olika länderna och antal flaskor från antal länder.

    Kan jag på något sätt få excell att automatiskt uppdatera cirkeldiagramet?

    Om jag har skrivit Italien 20 gånger i kolumn C. Hur får jag då excell att visa siffran 20 i kolumn D?

    Varje helg kommer det förnyas. Tack för svar!
     
    Last edited: 1 mars 2015
  2. mnor

    mnor Medlem

    Är det inte dags för Cellar Tracker? Vet inte om du kan få fram cirkeldiagram, men statistik får du i mängd.
     
    Vino fino gillar detta.
  3. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Jag har börjat använda CT också, jag har även lagt in all statistik där från förra året. Men jag vill lära mig excell också :) kan vara bra att kunna dom basala funktionerna!
     
  4. Vino fino

    Vino fino Medlem

    Du kan också dunka upp data direkt genom att importera ditt excelark till Cellartracker. Så slipper du knacka för hand.
     
  5. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Åh fan, önskar att jag hade vetat det i torsdags. Det tog en timme ungefär :p

    Vet du hur man gör?
     
  6. Vino fino

    Vino fino Medlem

    När du vill lägga till viner till din källare ("Add Wine to My Cellar") så finns det en funktion som heter "bulk upload a spreadsheet of your wines".
     
    magnum och Tomas Lindblom gillar detta.
  7. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Men det var ingen av er som visste hur man gjorde i excell?
     
  8. Bearman

    Bearman a´lea iacta est iterum

    =ANTAL.OM(C2:C21;"Italien") eller =COUNTIF(C2:C21,"Italien"), beroende om du har svensk eller engelsk version.
     
    magnum gillar detta.
  9. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Tack! Du är en ängel :D
    Jag ska försöka att lära mig lite mer om excel. Roligt program.

    Vet du vad det är för kommando om man vill att den gör samma sak, fast att den ska hämta data från ett annat blad?

    Jag har nämnligen informationen om vilket vin jag har druckit på blad 1.
    Sedan har jag cirkeldiagramet på blad 2.

    Det borde ju vara någonting före C2:C21?
     
    Bearman gillar detta.
  10. Bearman

    Bearman a´lea iacta est iterum

    e
    Tex: =ANTAL.OM(Blad1!C2:C21;"Italien") där man refererar till ett annat blad, i detta exempel Blad1.

    Uppdateringen av diagrammen borde vara automatiskt om du satt upp cellreferenserna rätt.. C2 till C21 är de rader som du vill skall beräknas. Så om du lägger till viner i Excel arket måste du utöka referensen... Nu är ju inte detta forumet ett Excel forum så jag hoppas övriga medlemmar har överseende med denna konversation:)
     
    Helen och Larseman gillar detta.
  11. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Det här va roligt! Nu är mitt egna hemmasnickrade excell-ark skräddarsytt för mig och den uppdaterar faktiskt formulan och allting blir rätt! :D
     
  12. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    upload_2015-3-1_20-45-33.png
     

    Bifogade filer:

    Helen gillar detta.
  13. magnum

    magnum Epernay, Frankrike

    Men inte om man lägger till mellan C2 och C21, eller?
     
  14. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Jo, jag gjorde så att jag la det från C1:C9999 för att få den att uppdatera all ny information automatiskt.

    Om det var din fråga?
     
  15. magnum

    magnum Epernay, Frankrike

    Då borde du vara ¨safe¨ i ett par år!
     
    JakobZ och Tomas Lindblom gillar detta.
  16. KimHartman

    KimHartman Medlem

    Kanske ett litet VBA-makro för att automatiskt sortera också? Ngt i stil med

    Private Sub Worksheet_Change(ByVal Target As Range)
    Worksheets("Blad1").Range("A1:B11").Sort Key1:=Worksheets("Blad1").Range("B1"), Key2:=Worksheets("Blad1").Range("A1"), Order1:=xlDescending, Order2:=xlAscending, Header:=xlYes
    End Sub
     
    magnum gillar detta.
  17. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Intressant, ska kolla på detta i veckan!
    Hur har ni lärt er om excell? Kurs? Självlärd? Via jobbet?
     
  18. Tomas Lindblom

    Tomas Lindblom fd Deppodi Moderator

    Någon som vet vad det är för formel för följande funktion? (Jag har engelsk version).

    Jag vill att excell räknar ut % av totalen.

    I cellen B17 så visas totalen.
    I B2 visas det hur många gånger jag har skrivit in "Frankrike" i Blad 1.

    Jag vill att den räknar "Frankrike" (Som är 7 gånger) och sedan delar 7 med totalen (Som är 39).

    Hmm..
     
  19. Bearman

    Bearman a´lea iacta est iterum


    =B2/$B$17 i cell C2, ändra formatet till procent. Sedan kan du kopiera denna och klistra in den för samtliga länder inkl totalen
     
    Last edited: 2 mars 2015
    Tomas Lindblom gillar detta.
  20. KimHartman

    KimHartman Medlem

    Självlärd i grunderna via jobbet eftersom vissa envisas med att använda det. Får jag data i ett excel-ark och får bestämma själv blir min första åtgärd att öppna Mathematica och skriva Import["fil.xlsx"] :p
     
    Elvis gillar detta.

Dela sidan